浅谈conda安装nodejs版本过低问题的解决方法


本文摘自PHP中文网,作者青灯夜游,侵删。

本篇文章给大家介绍一下解决conda安装nodejs出现的版本过低问题的方法。有一定的参考价值,有需要的朋友可以参考一下,希望对大家有所帮助。

相关推荐:《nodejs 教程》

在使用jupyterlab试图安装新的labextension时,出现了安装nodejs版本过低的问题,很多扩展模块一直无法安装或者安装失败的问题,笔者找了各种解决方法,如下:

  • 方法一:服务器上部署Anaconda与JupyterLab

  • 方法二:删包再安装包

  • 方法三:Jupytelab 如何安装 labextension

  • 方法四:通过npm安装nodejs
  • 方法五:狸猫换太子-如下图:

    在这里插入图片描述



结果…都不行。当然,你们也可以试试上面的方法,说不定哪一种能够用得上。

原因分析

后来发现:labextension安装扩展插件,需要nodejs 10.0以上的版本!!!
笔者通过查询自己的环境下各个nodejs版本发现,大部分版本

1

2

3

1. nodejs --version   # v14.4.1 这个是通过方法四安装的

2. pip list                  # v0.1.1 这个是通过pip安装的

3. conda list             # v4.6.5 这个是通过conda安转的

通过npm安装的nodejs虽然超过了v10.0,但是在jupyterlab环境下不能够使用(如果有发现可以使用,请和我交流交流)。发现安装的版本太多,索性卸载了pip conda安装的nodejs,再想办法安装超过v10.0的nodejs版本。

解决方案

指定安装版本,可以通过如下命令进行安装:

方法1 首先可以试着搜索一下nodejs的版本:

1

2

conda search nodejs # 搜索conda下的nodejs版本。

conda install nodejs=14.7.0 -c conda-forge

方法2. conda search nodejs -c conda-forge #搜索conda-forge下的nodejs版本.

或者直接进入到anaconda官网下的conda-forge搜索你想要的repo

1

conda install -c conda-forge/label/cf202003 nodejs

上面方法,任选一个就行

更多编程相关知识,请访问:编程视频!!

以上就是浅谈conda安装nodejs版本过低问题的解决方法的详细内容,更多文章请关注木庄网络博客

相关阅读 >>

nodejs怎么创建文件

3个值得收藏的实用nodejs软件包

详解使用docker给nodejs程序打包的方法

浅谈nodejs如何进行多线程处理

node.js安装和配置环境以及部署项目的方法介绍(windows系统下)

nodejs学习之了解域名解析模块dns

nodejs+robotjs实现控制鼠标键盘功能

详解nodejs+nest实现的短链接服务

详解nodejs中的querystring模块

nodejs的爬虫框架superagent

更多相关阅读请进入《conda》频道 >>




打赏

取消

感谢您的支持,我会继续努力的!

扫码支持
扫码打赏,您说多少就多少

打开支付宝扫一扫,即可进行扫码打赏哦

分享从这里开始,精彩与您同在

评论

管理员已关闭评论功能...